• Visitors can check out the Forum FAQ by clicking this link. You have to register before you can post: click the REGISTER link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below. View our Forum Privacy Policy.
  • FREE webinar: What does a post IR35 reform CV look like? : Wed, Jul 28, 2021 7:15 PM - 8:15 PM BST More details here.

IP Stack (stuck)

Collapse
X
  •  
  • Filter
  • Time
  • Show
Clear All
new posts

    IP Stack (stuck)

    heres the deal I'm using Win2kpro
    I loaded and can log into AOL (v7) BUT
    Can't access the web
    I can using other ISP's no prob and it's obviously fine co's I'm writing this!!!

    After going through 15,000 layers of AOL technical support, their final expert asked me to ping 127.0.0.1 as this is an internal IP stack address on the PC (?) I was not connected to anything at the time. The request timed out and the techie advised that this was an internal PC fault.

    I don't know that much about IP stacks so is this the case or is it a 'sod off we can't be bothered with you' AOL issue?

    PC normally picks up an IP address of of the DHCP server etc and from other ISP (incl AOL) when connecting...

    What's the deal then eh? Cheers!

    #2
    that sounds like tosh to me.

    127.0.0.1 is the default address of your localhost machine. it is not stored in an ip stack. afaik it is a registry setting. i would say that something else is causing your issue with aol. check that you have correct proxy settings for aol (i have no idea what they should be)

    Comment


      #3
      Re: that sounds like tosh to me.

      Thanks ScotsPine

      I thought it most likely something like that. Problem is AOL tech supp won't deal with it now as they have decided as I cannot 'ping my own machine' there is something wrong my end.

      Amazing eh? even after 15,000 layers of tech support, you still get a banana Bet they laid off all their contract staff too!

      Comment


        #4
        hmmm.

        ScotsPine is right that 127.0.0.1 is the reserved address for the local loopback interface. AOL are correct that if you cannot ping 127.0.0.1 you are not going to get anywhere with their service. They are probably wrong as to the reasons - never underestimate the stupidity of an isp's helpdesk. If the modem is your only connection device then the problem could well be theirs ( or their installers)

        what do you get with "ipconfig /all" ?

        Never used AOL (Arseholes On Line) - I always thought it was for thick americans - thats the impression you get on usenet.

        presumably it sets itself up to do dhcp and supply ip, route and dns addresses.

        What do you have set up in your network config ? How did you configure aol ? Do you have local networking / net cards installed ?

        What happens when you try to connect ? Presumably with a modem - can you see how far it gets and what happens ? (dials? answers ? atempts to authenticate ?)

        Gosh, the possibilities are endless....

        Comment


          #5
          Re: hmmm.

          This was Stand alone mode


          This was when connected to my office RAS


          This was pinging Known web sites through the RAS


          This connected to UK2.net (other ISP)


          Pinging from UK2


          This when connected to AOL


          And to complete the set (you knew this was coming didn't ya


          Bottom line I can connect to AOL but once there I get no web access.

          I tried pinging 127.0.0.1 from another win2k PC timed out again!!(no aol on this one though) - gawd knows 8)

          Comment


            #6
            Re: hmmm.

            Mark Snowden is probably the guy to helk here.
            When you are connected to RAS your config includes the 192.168.0.66 address (this is the microsoft default range when you have a pirvate network / LAN).
            I am running 2 machines using internet connnection sharing and the local machine was remapped from 127.0.0.1 to 192.168.0.1 etc.
            I cannot ping 127.0.0.1 but have full access to the internet but don't use AOL.
            127.0.0.1 is also used as the ip address of a local web server (personal web or IIS) ~ check whether any of these services are running.
            I have also seen some external hardware like cameras try and use 127.0.0.1 which can cuase contention.

            Comment


              #7
              AOL

              first thing I notice is that you never have dhcp enabled. So all your addresses are static.
              Second is that your aol example shows two interfaces. rather than one Have you got something else connected at the same time ? Have you installed aol twice ?

              when you try to connect to aol can you ping either of the two ip addresses given ? If so can you ping the gateways ?
              what about if you disable one of the interfaces ? (right clicl network places - properties to see the interfaces then double click on each one to see their status and individual properties and to be able to disable each one.

              thanks for the vote of confidence Karl ! But as I am, more of a unix person I dont claim to know it all. And as I said I have never used aol and they dont seem to put anything on their web site that gives the real details.

              Comment


                #8
                Re: AOL

                Karl1 hi and thanks. The DHCP server (on the LAN/RAS) is set to work in the private range so yes you are quite right but it's no surprise (to me at least (lol)

                MarkS hi and thanks for the input...
                let me try give a bit more..
                never have dhcp enabled - well it is set to on the tcp/ip settings...(I don't know if that makes it better/worse)
                aol example shows two interfaces
                Yes I noticed that too! Their is a LAN card in the unit but it was connected to fresh air at the time...(same with the other pics above)
                Have you installed aol twice
                No I've removed it now in disgust -he he

                ping either of the two ip addresses given - which two sorry lost me there...

                I didn't try this but will poke about with it after lunch...same with:
                disable one of the interfaces

                Thanks for the assistance guys!

                Comment


                  #9
                  the two interfaces

                  the aol shows two intyerfaces, each with an IP address

                  62.55.50.117 and 172.180.102.222

                  although I have just realized that the net mask is 255.255.255.255 and the machines are their own gateways - very strange.

                  Do you have to use aol ?

                  Comment


                    #10
                    Re: the two interfaces

                    Mark hi and thanks again.

                    Okay this is what I did:
                    I just downloaded and installed AOL v7.0 direct from their web site. It installs okay (BTW I was on my LAN through the DHCP and into the DSL line)

                    So it figures out I have a LAN and a modem I let it connect and install on the LAN and we connect and have web access whoopee-do!

                    Now for the dial up test. I removed the LAN connection (unplugged cable) selected all the numbers and connected to AOL as per normal. (Perhaps I should have mentioned this before but I’d forgotten) For some reason it always hangs on the first dial in attempt. This is the report it gives on failure:

                    Attempt 1) [0808 996 9002 Free Phone Scotland (V90)] connection failed because the remote system refused the TCP link

                    Okay that was what I got when I was in Scotland but the essence is the same if the number dialled is not.

                    On the second dial (same number for access) bang! Straight in! and do I get web access? NOPE! I did another IPCONFIG /all and pinged every IP on the page (that was a lot of pinging BTW) every IP gave the same timed out response.

                    I don’t have to use AOL – It’s just that I subscribed as a backup and for when I’m travelling as it’s a free phone call (cheapskate) As I’ve been paying for 9 months and only came to use it last month I feel a bit cheated to say the least!

                    Scots Pine makes reference to the Proxy settings – I’m using (initially) the infernal AOL built in browser…(dunno if that’s important??)

                    Any more thoughts form the information above??

                    Comment

                    Working...
                    X