• Visitors can check out the Forum FAQ by clicking this link. You have to register before you can post: click the REGISTER link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below. View our Forum Privacy Policy.
  • Want to receive the latest contracting news and advice straight to your inbox? Sign up to the ContractorUK newsletter here. Every sign up will also be entered into a draw to WIN £100 Amazon vouchers!

Cisco 3750g ps-e

Collapse
X
  •  
  • Filter
  • Time
  • Show
Clear All
new posts

    Cisco 3750g ps-e

    Whilst on contract my manager has allowed me to play & learn with a CISCO switch.

    Where do I start ? I've never done anything with a cisco switch.

    I have it hooked up to a laptop and connected to a terminal session, but thats as far as I have gone with it.

    There is no GUI it's all command line stuff

    any ideas where I can start and learn with this.

    It's not needed at work it's purely for my own development.

    #2
    what is it you are trying to learn?
    The proud owner of 125 Xeno Geek Points

    Comment


      #3
      To start with the basics of configuring a switch,

      then hopefully if I can learn that, start using it and get it up and running, just for experience

      Comment


        #4
        Originally posted by DaveP View Post
        To start with the basics of configuring a switch,
        Type in some of the following commands to get a basic config on the switch:

        Switch Config
        -------------

        [Basic]
        -------
        enable
        conf t
        hostname
        [Configure Virtual Interface]
        int vlan 1
        ip address 192.168.1.254 255.255.255.0
        no shut
        exit
        [Configure Default Gateway]
        ip default-gateway 192.168.1.1
        end
        sh int vlan 1
        wr
        sh run

        [Security]
        ----------
        [protect privilege mode]
        conf t
        enable secret XXXXXXX
        no enable password
        service password-encryption

        [Protect Console Port Access]
        line con 0
        password XXXXXXX
        login

        [Protect Line VTY Access]
        line vty 0 4
        password XXXXXXX
        login

        [Login Banners]
        conf t
        banner motd @
        **********************************
        Unauthorized Access is Prohibited
        **********************************

        @
        end

        [Enable SSH]
        conf t
        username YYYYYY password XXXXXX
        ip domain-name xyz.co.uk
        crypto key generate rsa
        <1024>
        ip ssh version 2
        line vty 0 4
        tranport input ssh
        end

        [General Commands]
        [sh ip int brief]
        terminal monitor (shows all messages to VTY screen)
        sh mac address-table
        do ? (i.e. do sh run). runs the command from global conf mode

        [Switch Optimization]
        conf t
        line con 0
        logging synchronous
        exec-timeout 30 0
        no ip-domain lookup
        line vty 0 4
        logging synchronous (Retypes line automatically when messages are logged to monitor)
        exec-timeout 30 0 (Idle timeout)
        no ip-domain lookup
        end

        [Setting up aliases]
        conf t
        alias exec s show ip int brief (where: exec=mode, s=alias command for "show ip int brief")


        [Port Security]
        conf t
        int fastethernet 0/5
        switchport mode access (hardcoded as access port - connected to end device. Alternative is trunk!)
        switchport port-security
        switchport port-security max 1 (max 1 mac address)
        switchport port-security violation ?
        protect (allows max mac & blocks the rest)
        restict (allows max mac, blocks the rest & logs violation in Security Violation Count (see sho port security int fa 0/5)
        shutdown (shuts down port)
        switchport port-security mac-address ? (hardcoded mac or sticky)
        end
        sh port security int fa 0/5

        [To configure a range]
        int range fastethernet 0/2 - 24
        switchport port-security

        [Configure Speed & Duplex on Ports]
        conf t
        int fa 0/2
        duplex half | full
        speed 10 | 100
        end

        - Check settings using: show interface fa 0/2, etc
        Last edited by Spoiler; 25 September 2012, 13:20.

        Comment


          #5
          Have you tried: Shall we play a game?
          Will work inside IR35. Or for food.

          Comment

          Working...
          X