• Want to receive the latest contracting news and advice straight to your inbox? Sign up to the ContractorUK newsletter here. Every sign up will also be entered into a draw to WIN £100 Amazon vouchers!

email attachments

So wait a minute are you IT whizz kids telling me the protocol used in email transmission sucks?

Why has someone not invented a binary email protocol?

Would sending less data not be a green thing to do?

God you really are spectacularly, phenomenally stupid aren't you?

:laugh:laugh:laugh
 
I suspect that it’s to do with the email system you are using that wants to attachments as preview. If you select Text rather than HTML it may make a difference.



I don't see that. the files are already in binary and the coding should not change infact you can Zip files and make them smaller to send thru email.


Be my friend on facetube

It doesn't matter whether you zip binary attachments or not, the size of the email will always be bigger as the email protocol dictates attachments are encoded into printable text characters, so each binary byte become multiple text characters on the wire.

Decoding Internet Attachments - A Tutorial

It's because the Internet and Email was invented by Unix geeks. If Microsoft had invented all this stuff everything would be binary, proprietary and require upgrades every two years.

HTH BIDI
 
So wait a minute are you IT whizz kids telling me the protocol used in email transmission sucks?

Why has someone not invented a binary email protocol?

Would sending less data not be a green thing to do?

A lot of email gateways only pass 7 bits of each byte. That's a historic thing going back to the days when email was just printable text, and didn't even support accented characters.

As a result email protocols were designed to translate messages in a way that would get through.

Outlook has long been an offender here, even encoding messages which don't need encoding.
 
So wait a minute are you IT whizz kids telling me the protocol used in email transmission sucks?

Why has someone not invented a binary email protocol?

Would sending less data not be a green thing to do?

When the ARPANET (which eventually became the Internet) was young, its use was restricted to some universities, government, the military, and a small number of companies (usually military contractors and/or telecommunications companies). In those olden times, getting computers to talk to each other was very tricky, for Unicode had not yet been thought of, and US-ASCII was the most widely-used character encoding standard.

US-ASCII is a 7-bit encoding, and this made it difficult to send 8-bit bytes, as even computers which had 8-bit bytes (which not all did) would oftentimes be running software which assumed that the eighth bit could be ignored or thrown away. When such systems were connected to the network and messages passed through them on the way to their destination, the concomitant corruption of the eighth bit caused weeping and wailing and gnashing of teeth. For some systems left the eighth bit alone, and some set it, and some reset it.

Then Jon Postel, who was much cleverer than the rest of us, wrote RFC821, which specified that email would use 7 bits, and the eighth bit would always be zero. And there was much rejoicing, for now it was possible to send messages concerning Star Trek (TOS, obviously) and patterns of Xs that looked a bit like naked ladies if you stood a long way away and squinted and had a vivid imagination, even from one university unto another, or to any of the other couple of hundred computers that comprised the net in those days.

But it came to pass that the netizens wanted to send proper pictures of naked ladies, one unto the other, because their university department had just got this really cool scanner that operated at, like, 72dpi and only cost a quarter of a million bucks.

Therefore Borenstein and Freed did publish RFC1521, which drew upon the encoding scheme described in RFC1421 to define a Base64 encoding scheme, which allowed 8-bit bytes to be converted into characters that could be represented in 6 bits (specifically, ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/) . And the netizens did rejoice, and sent pictures of naked ladies back and forth; and each picture was about 137% of the size (in bytes) it had been in the original 8-bit encoding, but that didn't matter because it was a small price to pay for seeing pictures of boobies.

And it hasn't broken yet, so they haven't fixed it. More accurately, although there are specifications allowing for 8-bit email transmission, nobody bothers to implement them because it isn't worth the hassle.
 
When the ARPANET (which eventually became the Internet) was young, its use was restricted to some universities, government, the military, and a small number of companies (usually military contractors and/or telecommunications companies). In those olden times, getting computers to talk to each other was very tricky, for Unicode had not yet been thought of, and US-ASCII was the most widely-used character encoding standard.

US-ASCII is a 7-bit encoding, and this made it difficult to send 8-bit bytes, as even computers which had 8-bit bytes (which not all did) would oftentimes be running software which assumed that the eighth bit could be ignored or thrown away. When such systems were connected to the network and messages passed through them on the way to their destination, the concomitant corruption of the eighth bit caused weeping and wailing and gnashing of teeth. For some systems left the eighth bit alone, and some set it, and some reset it.

Then Jon Postel, who was much cleverer than the rest of us, wrote RFC821, which specified that email would use 7 bits, and the eighth bit would always be zero. And there was much rejoicing, for now it was possible to send messages concerning Star Trek (TOS, obviously) and patterns of Xs that looked a bit like naked ladies if you stood a long way away and squinted and had a vivid imagination, even from one university unto another, or to any of the other couple of hundred computers that comprised the net in those days.

But it came to pass that the netizens wanted to send proper pictures of naked ladies, one unto the other, because their university department had just got this really cool scanner that operated at, like, 72dpi and only cost a quarter of a million bucks.

Therefore Borenstein and Freed did publish RFC1521, which drew upon the encoding scheme described in RFC1421 to define a Base64 encoding scheme, which allowed 8-bit bytes to be converted into characters that could be represented in 6 bits (specifically, ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/) . And the netizens did rejoice, and sent pictures of naked ladies back and forth; and each picture was about 137% of the size (in bytes) it had been in the original 8-bit encoding, but that didn't matter because it was a small price to pay for seeing pictures of boobies.

And it hasn't broken yet, so they haven't fixed it. More accurately, although there are specifications allowing for 8-bit email transmission, nobody bothers to implement them because it isn't worth the hassle.

Good way to kill thread Nick :tongue
 
When the ARPANET (which eventually became the Internet) was young, its use was restricted to some universities, government, the military, and a small number of companies (usually military contractors and/or telecommunications companies). In those olden times, getting computers to talk to each other was very tricky, for Unicode had not yet been thought of, and US-ASCII was the most widely-used character encoding standard.

US-ASCII is a 7-bit encoding, and this made it difficult to send 8-bit bytes, as even computers which had 8-bit bytes (which not all did) would oftentimes be running software which assumed that the eighth bit could be ignored or thrown away. When such systems were connected to the network and messages passed through them on the way to their destination, the concomitant corruption of the eighth bit caused weeping and wailing and gnashing of teeth. For some systems left the eighth bit alone, and some set it, and some reset it.

Then Jon Postel, who was much cleverer than the rest of us, wrote RFC821, which specified that email would use 7 bits, and the eighth bit would always be zero. And there was much rejoicing, for now it was possible to send messages concerning Star Trek (TOS, obviously) and patterns of Xs that looked a bit like naked ladies if you stood a long way away and squinted and had a vivid imagination, even from one university unto another, or to any of the other couple of hundred computers that comprised the net in those days.

But it came to pass that the netizens wanted to send proper pictures of naked ladies, one unto the other, because their university department had just got this really cool scanner that operated at, like, 72dpi and only cost a quarter of a million bucks.

Therefore Borenstein and Freed did publish RFC1521, which drew upon the encoding scheme described in RFC1421 to define a Base64 encoding scheme, which allowed 8-bit bytes to be converted into characters that could be represented in 6 bits (specifically, ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/) . And the netizens did rejoice, and sent pictures of naked ladies back and forth; and each picture was about 137% of the size (in bytes) it had been in the original 8-bit encoding, but that didn't matter because it was a small price to pay for seeing pictures of boobies.

And it hasn't broken yet, so they haven't fixed it. More accurately, although there are specifications allowing for 8-bit email transmission, nobody bothers to implement them because it isn't worth the hassle.

That doesn't explain why his 7MB attachment makes a 21MB email. That has to be because he's using a mac.
 

Advertisers

Back
Top