• Visitors can check out the Forum FAQ by clicking this link. You have to register before you can post: click the REGISTER link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below. View our Forum Privacy Policy.
  • FREE webinar: What does a post IR35 reform CV look like? : Wed, Jul 28, 2021 7:15 PM - 8:15 PM BST More details here.

cgi on Cobalt RaQ

Collapse
X
  •  
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    perl/cgi on UNIX, just like the old days
    sign...

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: chown and chmod

    Ta guys - think I understand that!

    Leave a comment:


  • Guest's Avatar
    Guest replied
    chown and chmod

    chown and chmod change the file permission information on files.

    chmod changes the access rules to the file (who has read, write and execute access to the file). Permissions are set on three levels, the individual user who owns the file, the group of users that own the file and everyone else. Chmod 777 gives everyone read, write and execute access to a file chmod 400 gives the owner of the file (and only the owner of the file) read access only.

    Chown allows you to change the owner of the file. chown ben script.cgi changes the owner of script.cgi to the user ben (if he exists).

    For a script to run on unix (be it a cgi program or anything else you want to run) you need to ensure that the user who wants to run the file has executable rights to it (say by entering chmod 755 script.cgi on the command line).

    Furthermore there is a weird issue with the httpduser on cobalt and files owned by the admin / root users. The easiest solution I've used is to telnet or ssh into the server as admin, change user to root, create another user and chown any cgi scripts on the server to that user).

    Leave a comment:


  • Guest's Avatar
    Guest replied
    chown

    usage
    chown [:] filespec

    (bet the board screws that up)

    chown fredeople myfil*

    will change the files matching myfil* to be owned by user fred and the owning group set to people

    if the file was originally
    -rwxr-wr-w jon staff myfile1

    ls -l will then give
    -rwxr-xr-x fred people myfile1

    In this case I think eek is saying that the best user to own the scripts is user httpdthe and group httpddaemon (or vv)

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: Its a permissions issue

    Eek - thanks very much for your comment, but being a complete ignoramus in this area I don't really understand what chowning the script or h..ding the h..daemon really means - can you elaborate a bit?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Its a permissions issue

    Cobalt treat the admin user as a junior root. Best solution is simply to chown the script to someone else (or httpdthe httpddaemon) and everything will be fine.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: Come on xogoth - we are all on tenterhooks !

    Mark - have had a bit of a fiddle but no joy yet.Have not really had much time due to work (ech!) - nothing much for weeks and now I've got a major re-write and full retest to do by yesterday - may actually earn a whole 2k this month at this rate! Will let you know when get back to it.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Come on xogoth - we are all on tenterhooks !

    Is it working yet - what was the problem ?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: RE:cgi on Cobalt RaQ

    curious, why would the file extension make any difference? Surely, this, as I pointed out already, is UNIX and the interpreter loaded is really going to depend on the shell magic ? And, I see that the cgi has the exec magic.

    Are you thinking of windoze and some weird file association thing from the registry?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    RE:cgi on Cobalt RaQ

    Sorry about the previouse. Bugger, this technology


    Try swapping your script extensions

    PL > CGI or
    CGI > PL

    Leave a comment:

Working...
X